use strict;
my $str = '"Mattias Asplund" 46 35000.00 070-6186120';
my $regex = qr/\"?([^\""]*)\"? \"?([^\""]*)\"? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";