$re = '/\"?([^\""]*)\"? \"?([^\""]*)\"? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})/';
$str = '"Mattias Asplund" 46 35000.00 070-6186120';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;