import Foundation
let pattern = #"^((([A-Z]{3})\-([0-9]{4})|([A-Z]{2}) ([A-Z]{2})\-([0-9]{3})|([A-Z]{4})\-([0-9]{3})|([A-Z]{5})\-([0-9]{2})|([A-Z]{6})\-([0-9]{1})|([A-Z]{3})\-([0-9]{3})|([A-Z]{4})\-([0-9]{2})|([A-Z]{5})\-([0-9]{1})))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ANH-1234
BRNO-123
HAROM-33
SZUPER-1
AA BE-123
HTC-123
FUGE-01
NEKEM-8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)