const regex = /^((([A-Z]{3})\-([0-9]{4})|([A-Z]{2}) ([A-Z]{2})\-([0-9]{3})|([A-Z]{4})\-([0-9]{3})|([A-Z]{5})\-([0-9]{2})|([A-Z]{6})\-([0-9]{1})|([A-Z]{3})\-([0-9]{3})|([A-Z]{4})\-([0-9]{2})|([A-Z]{5})\-([0-9]{1})))$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((([A-Z]{3})\\-([0-9]{4})|([A-Z]{2}) ([A-Z]{2})\\-([0-9]{3})|([A-Z]{4})\\-([0-9]{3})|([A-Z]{5})\\-([0-9]{2})|([A-Z]{6})\\-([0-9]{1})|([A-Z]{3})\\-([0-9]{3})|([A-Z]{4})\\-([0-9]{2})|([A-Z]{5})\\-([0-9]{1})))$', 'mg')
const str = `ANH-1234
BRNO-123
HAROM-33
SZUPER-1
AA BE-123
HTC-123
FUGE-01
NEKEM-8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}