use strict;
my $str = 'ANH-1234
BRNO-123
HAROM-33
SZUPER-1
AA BE-123
HTC-123
FUGE-01
NEKEM-8';
my $regex = qr/^((([A-Z]{3})\-([0-9]{4})|([A-Z]{2}) ([A-Z]{2})\-([0-9]{3})|([A-Z]{4})\-([0-9]{3})|([A-Z]{5})\-([0-9]{2})|([A-Z]{6})\-([0-9]{1})|([A-Z]{3})\-([0-9]{3})|([A-Z]{4})\-([0-9]{2})|([A-Z]{5})\-([0-9]{1})))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}