import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((([A-Z]{3})\\-([0-9]{4})|([A-Z]{2}) ([A-Z]{2})\\-([0-9]{3})|([A-Z]{4})\\-([0-9]{3})|([A-Z]{5})\\-([0-9]{2})|([A-Z]{6})\\-([0-9]{1})|([A-Z]{3})\\-([0-9]{3})|([A-Z]{4})\\-([0-9]{2})|([A-Z]{5})\\-([0-9]{1})))$";
final String string = "ANH-1234\n"
+ "BRNO-123\n"
+ "HAROM-33\n"
+ "SZUPER-1\n"
+ "AA BE-123\n"
+ "HTC-123\n"
+ "FUGE-01\n"
+ "NEKEM-8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}