re = /^((([A-Z]{3})\-([0-9]{4})|([A-Z]{2}) ([A-Z]{2})\-([0-9]{3})|([A-Z]{4})\-([0-9]{3})|([A-Z]{5})\-([0-9]{2})|([A-Z]{6})\-([0-9]{1})|([A-Z]{3})\-([0-9]{3})|([A-Z]{4})\-([0-9]{2})|([A-Z]{5})\-([0-9]{1})))$/m
str = 'ANH-1234
BRNO-123
HAROM-33
SZUPER-1
AA BE-123
HTC-123
FUGE-01
NEKEM-8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end