import Foundation
let pattern = #"\d{2}:\d{2}:\d{6,7}:\d*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
66:77:0066600:0000
66:11:0109003:627
66:44:0101033:378
66:27:1102019:25
66:27:1102017:6
66:27:1102033:93
66:27:1102043:21
: : :
: : :
66:11:180100:607
66:44:010101:725
66:16:260102:75
66:30:120113:163
66:30:120105:26
66:30:120106:34
66:30:120106:1
66:16:260101:3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)