package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{2}:\d{2}:\d{6,7}:\d*`)
var str = `66:77:0066600:0000
66:11:0109003:627
66:44:0101033:378
66:27:1102019:25
66:27:1102017:6
66:27:1102033:93
66:27:1102043:21
: : :
: : :
66:11:180100:607
66:44:010101:725
66:16:260102:75
66:30:120113:163
66:30:120105:26
66:30:120106:34
66:30:120106:1
66:16:260101:3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}