const regex = /\d{2}:\d{2}:\d{6,7}:\d*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}:\\d{2}:\\d{6,7}:\\d*', 'gm')
const str = `66:77:0066600:0000
66:11:0109003:627
66:44:0101033:378
66:27:1102019:25
66:27:1102017:6
66:27:1102033:93
66:27:1102043:21
: : :
: : :
66:11:180100:607
66:44:010101:725
66:16:260102:75
66:30:120113:163
66:30:120105:26
66:30:120106:34
66:30:120106:1
66:16:260101:3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}