// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{2}:\d{2}:\d{6,7}:\d*").unwrap();
let string = "66:77:0066600:0000
66:11:0109003:627
66:44:0101033:378
66:27:1102019:25
66:27:1102017:6
66:27:1102033:93
66:27:1102043:21
: : :
: : :
66:11:180100:607
66:44:010101:725
66:16:260102:75
66:30:120113:163
66:30:120105:26
66:30:120106:34
66:30:120106:1
66:16:260101:3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}