#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{2}:\d{2}:\d{6,7}:\d*"
Local $sString = "66:77:0066600:0000" & @CRLF & _
"66:11:0109003:627" & @CRLF & _
"66:44:0101033:378" & @CRLF & _
"66:27:1102019:25" & @CRLF & _
"66:27:1102017:6" & @CRLF & _
"66:27:1102033:93" & @CRLF & _
"66:27:1102043:21" & @CRLF & _
" : : :" & @CRLF & _
" : : :" & @CRLF & _
"66:11:180100:607" & @CRLF & _
"66:44:010101:725" & @CRLF & _
"66:16:260102:75" & @CRLF & _
"66:30:120113:163" & @CRLF & _
"66:30:120105:26" & @CRLF & _
"66:30:120106:34" & @CRLF & _
"66:30:120106:1" & @CRLF & _
"66:16:260101:3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")