import Foundation
let pattern = ##"(?=^.{8,}$)(?=[!@#%?&*!\\|]{1,})(?=^\S*$).*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #####"""
!123qwe@
asd32132
zxc123
xzc
123
####
xccx
cxqwe123qwesdaasd
ASD321asd
123123123123123
!123qwe@
!123QwE@
!123123
!123 123
!123123
"""#####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)