using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.{8,}$)(?=[!@#%?&*!\\|]{1,})(?=^\S*$).*$";
string input = @"!123qwe@
asd32132
zxc123
xzc
123
####
xccx
cxqwe123qwesdaasd
ASD321asd
123123123123123
!123qwe@
!123QwE@
!123123
!123 123
!123123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}