#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.{8,}$)(?=[!@#%?&*!\\|]{1,})(?=^\S*$).*$"
Local $sString = "!123qwe@" & @CRLF & _
"asd32132" & @CRLF & _
"zxc123" & @CRLF & _
"xzc" & @CRLF & _
"123" & @CRLF & _
"####" & @CRLF & _
"xccx" & @CRLF & _
"cxqwe123qwesdaasd" & @CRLF & _
"ASD321asd" & @CRLF & _
"123123123123123" & @CRLF & _
"!123qwe@" & @CRLF & _
"!123QwE@" & @CRLF & _
"!123123" & @CRLF & _
"!123 123" & @CRLF & _
"!123123 " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")