const regex = /(?=^.{8,}$)(?=[!@#%?&*!\\|]{1,})(?=^\S*$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.{8,}$)(?=[!@#%?&*!\\\\|]{1,})(?=^\\S*$).*$', 'gm')
const str = `!123qwe@
asd32132
zxc123
xzc
123
####
xccx
cxqwe123qwesdaasd
ASD321asd
123123123123123
!123qwe@
!123QwE@
!123123
!123 123
!123123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}