import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^.{8,}$)(?=[!@#%?&*!\\\\|]{1,})(?=^\\S*$).*$";
final String string = "!123qwe@\n"
+ "asd32132\n"
+ "zxc123\n"
+ "xzc\n"
+ "123\n"
+ "####\n"
+ "xccx\n"
+ "cxqwe123qwesdaasd\n"
+ "ASD321asd\n"
+ "123123123123123\n"
+ "!123qwe@\n"
+ "!123QwE@\n"
+ "!123123\n"
+ "!123 123\n"
+ "!123123 \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}