// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":[0-9]+(\/)(.*)(\/)([a-z]+.[a-z]+)").unwrap();
let string = "https://demchdc9scx.dc4ca.siemens.de:4300/Z_OP_APPLICATIONS/_Playground/JobReq/xs/ui/WebContent/CSS/styles.css";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}