import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":[0-9]+(\\/)(.*)(\\/)([a-z]+.[a-z]+)";
final String string = "https://demchdc9scx.dc4ca.siemens.de:4300/Z_OP_APPLICATIONS/_Playground/JobReq/xs/ui/WebContent/CSS/styles.css";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}