const regex = /:[0-9]+(\/)(.*)(\/)([a-z]+.[a-z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':[0-9]+(\\\/)(.*)(\\\/)([a-z]+.[a-z]+)', 'g')
const str = `https://demchdc9scx.dc4ca.siemens.de:4300/Z_OP_APPLICATIONS/_Playground/JobReq/xs/ui/WebContent/CSS/styles.css`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}