using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[0-9]+(\/)(.*)(\/)([a-z]+.[a-z]+)";
string input = @"https://demchdc9scx.dc4ca.siemens.de:4300/Z_OP_APPLICATIONS/_Playground/JobReq/xs/ui/WebContent/CSS/styles.css";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}