re = /:[0-9]+(\/)(.*)(\/)([a-z]+.[a-z]+)/
str = 'https://demchdc9scx.dc4ca.siemens.de:4300/Z_OP_APPLICATIONS/_Playground/JobReq/xs/ui/WebContent/CSS/styles.css'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end