use strict;
my $str = '
public static KLADEBOL10:Timagefont=LoadImageFont(KladebolUrl,10*2,ImageFontStyle);
public static MainChannel:TChannel=AllocChannel();
public void KeyCodeToString:String(Int keycode)
{
public void GetListByName:TList(string nm)
{';
my $regex = qr/(\w+):(\w+)/mp;
my $subst = '$2 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";