const regex = /(\w+):(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+):(\\w+)', 'gm')
const str = `
public static KLADEBOL10:Timagefont=LoadImageFont(KladebolUrl,10*2,ImageFontStyle);
public static MainChannel:TChannel=AllocChannel();
public void KeyCodeToString:String(Int keycode)
{
public void GetListByName:TList(string nm)
{`;
const subst = `$2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);