import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+):(\\w+)";
final String string = "\n"
+ "public static KLADEBOL10:Timagefont=LoadImageFont(KladebolUrl,10*2,ImageFontStyle);\n\n\n"
+ "public static MainChannel:TChannel=AllocChannel();\n\n\n"
+ " \n"
+ "public void KeyCodeToString:String(Int keycode)\n"
+ "{\n\n"
+ " public void GetListByName:TList(string nm)\n"
+ "{";
final String subst = "$2 $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}