// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?P<MAT_92>\w{2}[\-\ ]?\d{2}[\-\ ]?\d{2})|(?P<MAT_92_05>\d{2}[\-\ ]?\d{2}[\-\ ]?\w{2})|(?P<MAT_05_19>\d{2}[\-\ ]?\w{2}[\-\ ]?\d{2})|(?P<MAT_20_F>\w{2}[\-\ ]?\d{2}[\-\ ]?\w{2})$
").unwrap();
let string = "
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}