import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<MAT_92>\\w{2}[\\-\\ ]?\\d{2}[\\-\\ ]?\\d{2})|(?P<MAT_92_05>\\d{2}[\\-\\ ]?\\d{2}[\\-\\ ]?\\w{2})|(?P<MAT_05_19>\\d{2}[\\-\\ ]?\\w{2}[\\-\\ ]?\\d{2})|(?P<MAT_20_F>\\w{2}[\\-\\ ]?\\d{2}[\\-\\ ]?\\w{2})$\n";
final String string = "\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}