const regex = /^(?P<MAT_92>\w{2}[\-\ ]?\d{2}[\-\ ]?\d{2})|(?P<MAT_92_05>\d{2}[\-\ ]?\d{2}[\-\ ]?\w{2})|(?P<MAT_05_19>\d{2}[\-\ ]?\w{2}[\-\ ]?\d{2})|(?P<MAT_20_F>\w{2}[\-\ ]?\d{2}[\-\ ]?\w{2})$
/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<MAT_92>\\w{2}[\\-\\ ]?\\d{2}[\\-\\ ]?\\d{2})|(?P<MAT_92_05>\\d{2}[\\-\\ ]?\\d{2}[\\-\\ ]?\\w{2})|(?P<MAT_05_19>\\d{2}[\\-\\ ]?\\w{2}[\\-\\ ]?\\d{2})|(?P<MAT_20_F>\\w{2}[\\-\\ ]?\\d{2}[\\-\\ ]?\\w{2})$
', 'gmi')
const str = `
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}