re = /^(?P<MAT_92>\w{2}[\-\ ]?\d{2}[\-\ ]?\d{2})|(?P<MAT_92_05>\d{2}[\-\ ]?\d{2}[\-\ ]?\w{2})|(?P<MAT_05_19>\d{2}[\-\ ]?\w{2}[\-\ ]?\d{2})|(?P<MAT_20_F>\w{2}[\-\ ]?\d{2}[\-\ ]?\w{2})$
/mi
str = '
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end