package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?P<MAT_92>\w{2}[\-\ ]?\d{2}[\-\ ]?\d{2})|(?P<MAT_92_05>\d{2}[\-\ ]?\d{2}[\-\ ]?\w{2})|(?P<MAT_05_19>\d{2}[\-\ ]?\w{2}[\-\ ]?\d{2})|(?P<MAT_20_F>\w{2}[\-\ ]?\d{2}[\-\ ]?\w{2})$
`)
var str = `
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}