import Foundation
let pattern = #"^(?:[0-9]{1,3}\. ?)?(?:<media(?::[0-9]+)? ?/?><br ?/?>)*(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
What does the speaker suggest?
91. What does the speaker suggest?
96. <media:12 /><br />Why is the speaker going to Reynold’s Café?
96. <media:12 /><br /><media:13 /><br />Why is the speaker going to Reynold’s Café?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)