import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]{1,3}\\. ?)?(?:<media(?::[0-9]+)? ?/?><br ?/?>)*(.*)$";
final String string = "What does the speaker suggest?\n\n"
+ "91. What does the speaker suggest?\n\n"
+ "96. <media:12 /><br />Why is the speaker going to Reynold’s Café?\n\n"
+ "96. <media:12 /><br /><media:13 /><br />Why is the speaker going to Reynold’s Café?";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}