import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^\$?(?:\d+|\d*\.\d+|(?:\d{1,3},)?(?:\d{3},)*\d{3}|(?:\d{1,3},)?(?:\d{3},)*\d{3}\.\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1
123
1234567
1234567890
1,234
123,456
1,234,567
1,234,567,890
$1
$123
$1234567.890
$1234567890
$1,234
$123,456
$1,234,567
1.0
123.0
1234567.0
1,234.0
123,456.0
1,234,567.0
$1.0
$123.0
$123456.0
$1,234.0
$123,456.0
$1,234,567.987
.0
$.0
.01
$.02
1 12
1,23
1,234567
$
$,0
$1,0
1.1.1
1.
.
1,1
,1
1,1.0
1.1,0
,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)