use strict;
my $str = '1
123
1234567
1234567890
1,234
123,456
1,234,567
1,234,567,890
$1
$123
$1234567.890
$1234567890
$1,234
$123,456
$1,234,567
1.0
123.0
1234567.0
1,234.0
123,456.0
1,234,567.0
$1.0
$123.0
$123456.0
$1,234.0
$123,456.0
$1,234,567.987
.0
$.0
.01
$.02
1 12
1,23
1,234567
$
$,0
$1,0
1.1.1
1.
.
1,1
,1
1,1.0
1.1,0
,';
my $regex = qr/^\$?(?:\d+|\d*\.\d+|(?:\d{1,3},)?(?:\d{3},)*\d{3}|(?:\d{1,3},)?(?:\d{3},)*\d{3}\.\d+)$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}