using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$?(?:\d+|\d*\.\d+|(?:\d{1,3},)?(?:\d{3},)*\d{3}|(?:\d{1,3},)?(?:\d{3},)*\d{3}\.\d+)$";
string input = @"1
123
1234567
1234567890
1,234
123,456
1,234,567
1,234,567,890
$1
$123
$1234567.890
$1234567890
$1,234
$123,456
$1,234,567
1.0
123.0
1234567.0
1,234.0
123,456.0
1,234,567.0
$1.0
$123.0
$123456.0
$1,234.0
$123,456.0
$1,234,567.987
.0
$.0
.01
$.02
1 12
1,23
1,234567
$
$,0
$1,0
1.1.1
1.
.
1,1
,1
1,1.0
1.1,0
,";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}