#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^\$?(?:\d+|\d*\.\d+|(?:\d{1,3},)?(?:\d{3},)*\d{3}|(?:\d{1,3},)?(?:\d{3},)*\d{3}\.\d+)$"
Local $sString = "1" & @CRLF & _
"123" & @CRLF & _
"1234567" & @CRLF & _
"1234567890" & @CRLF & _
"1,234" & @CRLF & _
"123,456" & @CRLF & _
"1,234,567" & @CRLF & _
"1,234,567,890" & @CRLF & _
"$1" & @CRLF & _
"$123" & @CRLF & _
"$1234567.890" & @CRLF & _
"$1234567890" & @CRLF & _
"$1,234" & @CRLF & _
"$123,456" & @CRLF & _
"$1,234,567" & @CRLF & _
"1.0" & @CRLF & _
"123.0" & @CRLF & _
"1234567.0" & @CRLF & _
"1,234.0" & @CRLF & _
"123,456.0" & @CRLF & _
"1,234,567.0" & @CRLF & _
"$1.0" & @CRLF & _
"$123.0" & @CRLF & _
"$123456.0" & @CRLF & _
"$1,234.0" & @CRLF & _
"$123,456.0" & @CRLF & _
"$1,234,567.987" & @CRLF & _
".0" & @CRLF & _
"$.0" & @CRLF & _
".01" & @CRLF & _
"$.02" & @CRLF & _
"" & @CRLF & _
" 1 12" & @CRLF & _
"1,23" & @CRLF & _
"1,234567" & @CRLF & _
"$" & @CRLF & _
"$,0" & @CRLF & _
"$1,0" & @CRLF & _
"1.1.1" & @CRLF & _
"1." & @CRLF & _
"." & @CRLF & _
"1,1" & @CRLF & _
",1" & @CRLF & _
"1,1.0" & @CRLF & _
"1.1,0" & @CRLF & _
","
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")