// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^\$?(?:\d+|\d*\.\d+|(?:\d{1,3},)?(?:\d{3},)*\d{3}|(?:\d{1,3},)?(?:\d{3},)*\d{3}\.\d+)$").unwrap();
let string = "1
123
1234567
1234567890
1,234
123,456
1,234,567
1,234,567,890
$1
$123
$1234567.890
$1234567890
$1,234
$123,456
$1,234,567
1.0
123.0
1234567.0
1,234.0
123,456.0
1,234,567.0
$1.0
$123.0
$123456.0
$1,234.0
$123,456.0
$1,234,567.987
.0
$.0
.01
$.02
1 12
1,23
1,234567
$
$,0
$1,0
1.1.1
1.
.
1,1
,1
1,1.0
1.1,0
,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}