// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-za-z]{2}\d{4}|[A-za-z]{4}\d{2})").unwrap();
let string = "AABB12
BBAA12
AA12AA
BBAA12
AA1212";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}