$re = '/([A-za-z]{2}\d{4}|[A-za-z]{4}\d{2})/m';
$str = 'AABB12
BBAA12
AA12AA
BBAA12
AA1212';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);