using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-za-z]{2}\d{4}|[A-za-z]{4}\d{2})";
string input = @"AABB12
BBAA12
AA12AA
BBAA12
AA1212";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}