import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-za-z]{2}\\d{4}|[A-za-z]{4}\\d{2})";
final String string = "AABB12\n"
+ "BBAA12\n"
+ "AA12AA\n"
+ "BBAA12\n"
+ "AA1212";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}