package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-za-z]{2}\d{4}|[A-za-z]{4}\d{2})`)
var str = `AABB12
BBAA12
AA12AA
BBAA12
AA1212`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}