$re = '/^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$/m';
$str = 'verison.com
verison.net
verison.nte
verizon
verizon.com
verizon.cpm
verizon.ent
verizon.met
verizon.nbet
verizon.ne
verizon.net
verizon.net.
verizon.net.com
verizon.netjac
verizon.netormdeb
verizon.netosunnam
verizon.nmet
verizon.org
verizoncom
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);