use strict;
my $str = 'verison.com
verison.net
verison.nte
verizon
verizon.com
verizon.cpm
verizon.ent
verizon.met
verizon.nbet
verizon.ne
verizon.net
verizon.net.
verizon.net.com
verizon.netjac
verizon.netormdeb
verizon.netosunnam
verizon.nmet
verizon.org
verizoncom
';
my $regex = qr/^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}