using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$";
string input = @"verison.com
verison.net
verison.nte
verizon
verizon.com
verizon.cpm
verizon.ent
verizon.met
verizon.nbet
verizon.ne
verizon.net
verizon.net.
verizon.net.com
verizon.netjac
verizon.netormdeb
verizon.netosunnam
verizon.nmet
verizon.org
verizoncom
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}