package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$`)
var str = `verison.com
verison.net
verison.nte
verizon
verizon.com
verizon.cpm
verizon.ent
verizon.met
verizon.nbet
verizon.ne
verizon.net
verizon.net.
verizon.net.com
verizon.netjac
verizon.netormdeb
verizon.netosunnam
verizon.nmet
verizon.org
verizoncom
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}