import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$";
final String string = "verison.com\n"
+ "verison.net\n"
+ "verison.nte\n"
+ "verizon\n"
+ "verizon.com\n"
+ "verizon.cpm\n"
+ "verizon.ent\n"
+ "verizon.met\n"
+ "verizon.nbet\n"
+ "verizon.ne\n"
+ "verizon.net\n"
+ "verizon.net.\n"
+ "verizon.net.com\n"
+ "verizon.netjac\n"
+ "verizon.netormdeb\n"
+ "verizon.netosunnam\n"
+ "verizon.nmet\n"
+ "verizon.org\n"
+ "verizoncom\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}