re = /## \(#.*?\)/m
str = '## (#compact)`_.compact(array)`
## (#concat)`_.concat(array, [values])`'
subst = '## \\{#.*?\\}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result