use strict;
my $str = '## (#compact)`_.compact(array)`
## (#concat)`_.concat(array, [values])`';
my $regex = qr/## \(#.*?\)/mp;
my $subst = '## \\{#.*?\\}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";