package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)## \(#.*?\)`)
var str = `## (#compact)\`_.compact(array)\`
## (#concat)\`_.concat(array, [values])\``
var substitution = "## \{#.*?\}"
fmt.Println(re.ReplaceAllString(str, substitution))
}